Hot Potatoes

JQuiz - izrada kviza s pitanjima za koje treba izabrati jedan ili viSe tocnih odgovora ili

upisati kratki odgovor

JCloze - izrada zadatka s tekstom za dopunjavanje , korisnik mora prepoznati i u prazna

polja upisati rijeci koje nedostaju

JCross - izrada krizaljki

JMix - kvizovi s pomijeSanim redoslijedom rijeci u recenici ili redoslijedom elemenata

nekog popisa ili nabrajanja

JMatch - kreiranje zadataka kod kojih se vrsi uparivanje rijeci, pojmova, tablica ili slika

postavljenih u dva stupca

The Masher - program za povezivanje vise istovrsnih ili raznovrsnih kvizova u jednu

cjelinu



KREIRANJE KVIZA

- da bi dobili bilo kaoiji tip kviza / viezbe moramo obaviti slijedeée operacije

@ unoSenje podataka ( pitanja i moguéi odgovori, popratni tekst, slike i linkovi, ... )

@ odredivanje §to i u kom obliku ¢e se pojaviti na izlaznoj web stranici ( Configuration Output )
@ kreiranje same web stranice ( File > Create Web page )

OPERACIJE S DATOTEKAMA (File)

Da bi nade vjezbe kreirane u Hot Potatoes-u §to vedi

broj korisnika pronasao i lakSe koristio moguce je dati niz File Edit Insert Manage Questions Options  Help
opisnih informacija o toj vjezbi koje ¢e biti uklju¢ene u izlaznu 5 Mew Chrl+
web stranicu. Pomoc¢u File > Add Metadata dobijemo izbor & open Chrl+0
od 15 kategorija informacija o vjezbi koje moZemo upisati ( H save Chrl+s
npr. autor, datum, naslov, opis, ... ) B save as
Dvije vjezbe istog tipa mozemo pomoéu + Append
file spoijiti u jedinstvenu vjeZbu ( vrijedi za Jquiz, Jmatch ). 7 idd Reading Text  Ctrl+R
Dodavanje panela s popratnim tekstom uz neki kviz £ Add Metadata Chrl+h
vr§imo pomocéu File > Add reading text . Osim teksta i + Append File

njegovog naslova mozemo umetnuti i sliku, link, tablicu, neki
postoje¢i HTML dokument.Upozorenje : dodavanje teksta u
Jmix i Jmatch nije preporugljivo jer tekst zauzima pola Sirine
izlazne web stranice.

Pitanja iz naSih vjezbi mozemo i printati pomocu
Export fo printing ¢ime se vrsi prijenos sadrzaja na clipboard
odakle ga mozemo kopirati u neki tekst procesor npr. Word i
isprintati.

ﬁ Create Web page r
=4 Export for Printing  Crl+P
iﬂ Export for WebCT

UMETANJE (Insert)

SLIKE ,LINKA ILI HTML TABLICE
- objekte mozemo umetnuti uz naslov, pitanje, odgovor
- slika koju umec¢emo moze se nalaziti na nekoj web

adresi ili na lokalnom disku u istom folderu u kojem ée biti File Edit Insert Manage Questions Options Help
i krejrana wevb lsltranica sa vjeZbloml ,pdredujemo njgrju Ficture 3
veli¢inu, polozaj i tekst koji se pojavljuje prelaskom misa .
: ;ﬂ'ﬂ' Lirk. r
preko slike
- link koji umecéemo isto moze pokazivati na neku web HH AL Table  CuleT

adresu ili na neku datoteku u na lokalnom disku u istom W Media Object
folderu u kojem ce biti i kreirana web stranica sa vjezbom

- pri umetanju tablice odredujemo broj redaka i stupaca,

Sirinu tablice, debljinu obruba

UMETANJE OBJEKTA
- zvuk, video, flash objekt moze se umetnuti na dva nacina :

@ jednostavniji nacin je umetanje linka na datoteku koja sadrzi taj zvucni ili video zapis ( datoteka se otvara u
novom prozoru tj. pokre¢e u odgovarajucoj aplikaciji koja je instalirana na korisnikovom racunalu - kod
nekog korisnika je default player Windows Media Player kod drugog Quick Time )

@ drugi nacin je izbor player , izbor datoteke koju Ce taj player otvoriti unutar naSe web stranice s kvizom ( link
koji se moze ukljuciti je za slu€aj da player nije dostupan )



OPCIJE ( Options)

@ Font—mozZemo vrsiti izbor fonta , stila i

veli¢ine fonta File Edit Insert Manage Questions Options Help
] Tololb.alr options - |zbqr gumba koji ¢e se Mode
pojaviti na alatnoj traci

@ |Interface — imamo i moguc¢nost

%3 Configure Cukput
prevodenja, uCitavanja ili resetiranja

. AT rfF Fonk...
tekstova/oznaka koje se pojavljuju na b .
sucelju. 4= Right-to-Left
@ Configuration — nam nudi najvise Tookar Options
mogucnosti: lg Reload config info From file
= Titles/Instructions — naslov i upute @ Interface
= Appearance — odredujemo

grafiCki izgled stranice - boju
pozadine, slova,...

= Timer — vremensko ograni¢enje

= Other - pitanja i odgovori mogu se relativno sakriti tako da se oznaci opcija "Create separate linked file
containing JavaScript code" ¢ime se kreira posebna .js datoteka u kojoj su ta pitanja i odgovori .

= Buttons — pojavljivanje ili ne raznih gumba npr. na svakoj web stranici mozemo postaviti gumbe s
odgovaraju¢im URL adresama za sljedecu vjezbu, prethodnu vjezbu ili index datoteku .

= Custom - moze se definirati 3 niza znakova koji ¢e se u web stranici pojaviti tamo gdje smo u kvizu
upisali niz [strUserDefinedx] pri ¢emu je x jedan od brojeva 1,2,3 i odreduju o kojem nizu seradi , a
u zadnjem okviru mozemo definirati svoju JavaScript funkciju ili CSS kod koji ¢e pri kreiranju web
stranice biti umetnut u <head> element .

Kako se mogucnosti koje se pojavljuju u karticama prozora Configuration razlikuju ovisno o vrsti kviza to ¢ce
o karakteristicnim moguénostima biti govora kod svake vrste kviza.

JQuiz
JQuiz: [Untitled] =Joed
File Edit Insert Manage Questions Options Help
aeEHdE OB ¢ ; B | 2
Title | NASLOV VJEZBE - KVIZA
Q|1 j [Multiple-choice 7 -/
PLTANIE Weighting: (100 S
- .
= Answers Feedback Settings
ObGEOVOR 1 kamentar odgovora 1 [w Acceptas correct
A
a0 5 % correct
CObGOVOR 2 kamentar odgovaora 2 v Acceptas correct
B
100 5 % correct
ObGEOVOER 3 kamentar odgovara 3 [ Acceptas correct
C
0 5| Hecorrect
[~ Accept as correct
D
] 2 % correct

- izrada kviza s pitanjima za koje treba izabrati jedan ili viSe to€nih odgovora ili upisati kratki odgovor

- za svaki odgovor mozemo napisati objaSnjenje zasSto je taj odgovor to¢an ili neto¢an ili neki komentar (pod
Feedback)

-3-



- vrste pitanja :
@ Multiple-choice - izbor samo jednog od viSe ponudenih odgovora
@ Short-answer — upisivanje kratkog odgovora
@ Multi-select — treba izabrati viSe to¢nih odgovora
@ Hybrid — kombinacija Multiple-choice i Short-answer

- pri odredivanju kako ce izgledati web stranica ( Options > Configure Output ) pod Other — odredujemo :

broj pitanja koji ¢e se pojaviti na stranici (slu¢ajno izabrana pitanja medu postoje¢im pitanjima )
promjena redoslijeda pitanja pri svakom ucitavaniju,

promjena redoslijeda odgovora pri svakom ucitavanju,

broj to¢nih odgovora u prvom pokusaju, . . .

- u Options > Mode > Advanced mode dobijamo neke dodatne mogucnosti :

Question Weighting — odredujemo relativnu vaznost pojedinih pitanja u rasponu od 0 do 100

Percentage Correctness for Answers — bar jedan odgovor = ispravan odgovor mora imati to¢nost 100%
dok ostali odgovori mogu biti djelomi¢no to¢ni pa im mozemo dodjeliti manji postotak to€nosti

Accept as correct — prihvaca odgovor kao to¢an iako mu je postotak to¢nosti manji od 100% ( time se
zeli postic¢i efekt "zavrdenog" pitanja pa daljnji odgovori ne bi bili prihvaceni')

Question Weighting — odredujemo relativnu vaznost pojedinih pitanja u rasponu od 0 do 100

Percentage Correctness for Answers — bar jedan odgovor = ispravan odgovor mora imati to¢nost 100%
dok ostali odgovori mogu biti djelomi¢no to¢ni pa im mozemo dodjeliti manji postotak to¢nosti

Include in M/C options — pojavljuje se kod pitanja tipa hybrid kod kojih u prvoj fazi korisnik treba upisati
odgovor, ako nakon odredenog broja pokusaja ne uspije pitanje se pretvara u tip Multiple-Choice i ovom
opcijom odredujemo koji ¢e se od ponudenih odgovora pojaviti u M/C pitanju

Primjer izlazne web stranice:

oshovhi pojmovi informatike

Osijek, studeni 2006. -4 - Jasminka Brezak



Jclose

JCloze: C:\Documents and Settings\JB.0S-JB\Desktopimaterijalithotpotatoes-pr... E]@
File Edit Insert Options Help

aecEHE S8 BEWw®  ®BE | 2

Title Ispriéaj mi nesto o gradevinarstvu

=div style="text-align: center,"><aobject clagsid="clsid:dZ7 cdbbe-aebd-11cf95b3-444553540000"
codehase="http:fdownload. macromedia. com/pub/shockwave/cabs/fflash/swiflash. cab#version=
7014 0" type="application/x-shockwave-flash” width="300" height="150"> <param name="movig"
value="manta.swf" /= <a hreF="manta swf" title="monta. swf">tako edo gradi</a=</object>
<fdivz

Davno u prolosti jedan Eduard gradio je osjecku "katedrall”. Jedan prowelind biro danas nosi
njegovo ime. Osim imena zajednicke su im velike gradevine.

7 Gap ‘ i¢ Delete Gap ‘

& Clear Gaps | W Auto-Gap ‘ == Show Words ‘

Config: moj.cfg

— izrada zadatka s tekstom za dopunjavanje , korisnik mora prepoznati i u prazna polja upisati rijeci koje nedostaju
- kreiramo tako da odredimo koja ¢e rijec/tekst biti sakriven tako da kliknemo gumb GAP i za taj dio odredimo CLUE
( krace pojasnjenje o ocekivanom odgovoru ) i ako moze biti jo$ koji to€an odgovor
- Configuration Output nam nudi mogucnosti :
@ Use dropdown list instead of textbox in output - umjesto prazne kuéice za upis odgovora nudi nam
padajucu listu sa svim odgovorima koji se pojavljuju u toj viezbi ( nema Hint gumba )
@ Include word list with text — pokazat ¢e sve odgovore iz te viezbe izmjeSanim redoslijedom iznad teksta
viezbe
@ Include a keypad to help student type non-roman characters — prikaz tipkovnice , a moze se upisati i
posebne znakove koji se trebaju uvijek pojaviti ( u prostor ispod Always include these characters on
the keypad )
@ odrediti da li ¢e se ili ne pojaviti CLUE gumb , kao i HINT gumb ( daje malu pomo¢ npr. prvo slijedece
slovo u odgovoru )

Primjer izlazne web stranice:

Ispri¢aj mi nesto o gradevinarstvu

Zadaci za nadopunjavanje

Fopuni praznine,a zatim klikni "Provier” da bi provierio svoje odgovore.

Davno u proslost jedan ~|gradio je osjecku " *|biro danas nosi njegovo
ime . Osim imena zajednitke suim velike A

Provieri |




Jcross

JCross: C:\documents and Settings\JB.0S-JB\Desktop\materijalithotpotatoe. .. g@
File Edit Insert Manage Grid ©Options Help
aecHBSEY | o L e | o B o2 | |
- . F
Title —1o s
L H
oA T O T E K A
E R
K E R ME L D =]
| WO DD WS
L A F
Q J R T
B M P E Wy
&, Add Clues = & A
T R
A E E
< >
v
|C0nfig: hirwatskic. cfg |Grid size: 16 x 13 ]

— izrada krizaljki pri ¢emu je dovoljno je upisati pojmove ( tako da se iz izbornika Manage Grid odabere Automatic
Grid-Maker i program sam kreira krizaljku )

- da bi korisnik mogao upisati trazeni pojam, mora se dati neko objasnjenje ili opis tog pojma §to se radi pomocu
Add Clues.

- nema moguénost umetanja tablice, media objekta

Primjer izlazne web stranice:

KriZaljka a)

____ESEn

1

H
n n

E3
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JMix

JMix: C:ADocuments and Settings\JB.05- JB\Desktop\materijalithotpota. .. u@ﬁ
File Edit Insert Options Help

pecHRCE®EY | - L on | B | 2 | |

Title Redoslijed operacija
Main sentence Alternate sentences

potenciranje s 1 potenciranjedijeljenjemnoZ
mroZenje - enjezbrajanjeoduzimanie
dijeljenje

zhrajanje 2 patenciranje mnoZenje &]
oduzimanje dijeljenje oduzimanje M

3

—Options for alternate sentence

& Allow sentences which do not use all words and punctuation in main sentence.

" Warn if alternate sentence does not use all words and punctuation in main sentence.

|Cnnfig: hirwakskis, cfg -

- kvizovi s pomijeSanim redoslijedom rije¢i u rec€enici ili redoslijiedom elemenata nekog popisa ili nabrajanja a
korisnik treba odrediti ispravan redoslijed y

- u ovom obliku kviza mozemo kreirazi tri dodatne opcije u obliku gumba UNDO ( PONISTI prethodnu akciju) ,
HINT ( pomoé ) , RESTART ( POCNI PONOVO )

- izlazna web stranica moze biti standardni nacin rjeSavanja ( klikanjem) ili drag-and-drop ( povlacenjem objekata)

Primjer izlazne web stranice:

Redoslijed operacija

Zadatak s pomijesanim redoslijedom

]
L eew | eewwe Jem]
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JMatch

[¥] JMatch: C:\Documents and Settings\JB.05-JB\Desktopimaterijali\hotpotatoes-programimatch1. jmt g@
File Edit Insert Manage Items Options Help
aeHEHCBERY R | EEATwe B 2
Title <strong>TraZenje parova</strong>
Left {ordered) items Right (jumbled) items Fix
A dijelovi racunala hardware
= 1 =
rogrami software
2 prog =
chranjeni podaci ili program datoteka
3 P ent p prog -
[skup datoteka u vanjskoj mermorii folder
4 P I|=k0] I -
5 u
Default: izaberi togan odgovar
CUnFig: moj.cfg

- kreiranje zadataka kod kojih se vr&i uparivanje rijeci, pojmova, tablica ili slika koje su postavljene u dva stupca

- tri vrste rjeSavanja standardno ( klikanjem ) , drag-and-drop ( povlacenjem objekata ) i u obliku flash kartica ( Sto
nije rjieSavanje zadatka vec prikazivanje parova — za lakSe ucenje)

- feedback je ograni¢en samo na to¢no/netocno

- drag-and-drop nacin uparivanja nije dobar ako postoji veliki broj parova ( mora se skrolati ekran ) i idealno ga je
koristiti ako imamo do 8 elemenata

Primjer izlazne web stranice:

TraZenje parova

Zadanom elementu pridruZi odgovor iz padajuceqg izbormika.

Frovier

software | izaberi tocan odgovor _v':'
folder  |izaberi tofan odgovor il
datoteka | izaberi tocan odgovor v
hardware | izaberi toZan odgovar |4
izaber tocan odgovor
programi

skup datoteka U vanjsko] memoriji
pohranjeni podaci ili program
dijelovi racunala




Primjer izlazne web stranice ( flash cards ):

u B

The Masher

m

File Actions Options  Hotpotatoss,pet  Help

ecHE ¢ EOR W2 |

Files |App§arance| User strings | Buttans | 50urce| Index |

Data file I Output file name | Mext exercise file name Cutput type

Eclnze.jcl cloze. htm kviz.htm Standard
kviz.jqz kviz.htm rmatch1.htm Standard gt
mmatch'l it match. kit Standard

b

+ Add files | = Delete file |
Qutput falder:
= Browse... |

# Build unit |

- program za povezivanje vise raznih kvizova u jednu cjelinu ( samo uz komercijalnu licencu , free verzija dozvoljava
povezivanje do 3 zadatka) pri éemu u svakoj viezbi moZzemo imati gumbe za slijedecu ili prethodnu vjezbu
- pri kreiranju cjeline stvara se html datoteka ( default ime je index.html ) koja prikazuje sadrzaj te cjeline
- mogucénosti : Appearance - pojedinie viezbe mogu zadrzati svoj izgled ili se kreira izgled koji ¢e biti isti za sve
vjezbe u cjelini ( podloge, boje, font )
Buttons -  prikaz ili ne gumba za slijedec¢u, prethodnu vjezbu ili sadrzaj
Index - naslov koji se pojavljuje u stranici sa sadrzajem cjeline te ime datoteke u kojoj je
sadrzaj ( default index.html )
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